Discussion:
'pm install', 'am start' in debug terminal doesn't do anything
(too old to reply)
jack zhang
2018-11-12 22:02:31 UTC
Permalink
I'm trying to install an APK and run the app's APK under 'debug mode'
terminal.



1) During starting up, in the Grub Menu, #2 (Android-x86 6.0-r2 (Debug
mode)) is chosen.



*Android-x86 6.0-r2*

*Android-x86 6.0-r2 (Debug mode)*

*Android-x86 6.0-r2 (Debug nomodeset)*

*Android-x86 6.0-r2 (Debug video=LVDS-1:d)*



2) At the terminal '(debug-found)@android:/android #', I typed following (APK
file named 'app-debug.apk', it is in the path '/mnt/app-debug.apk), the
terminal returns without doing anything, see attached screen shot
'grub-option2-debug-terminal.png'.


*pm install -r -d /mnt/app-debug.apk*


3) If I used the same command 'pm install ...' inside 'Android Terminal'
after 'Desktop' is launched, it works fine.



see attached screen shot 'grub-option1-android-terminal.png'.


same problem with command 'am start', when I typed 'am start -n
PACKAGE_NAME/.ACTIVITY_NAME', it runs the app from 'Android Terminal', but
doesn't do anything in terminal '(debug-found)@android:/android#'.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Continue reading on narkive:
Loading...