Discussion:
Oreo Custom ISO missing Google Play and Setup Crashes
(too old to reply)
BrokenE39
2018-08-10 18:38:10 UTC
Permalink
I gave up on just copying the kernel and drivers over to a generic install
since I couldn't get "module_install" to run without errors. I manage to
build an ISO image based on custom configuration file but I notice the
following issues:

1. On first start up, I don't see the typical setup wizard

2. Notice Google Play is missing which isn't missing if I use the generic
ISO

3. Setup crashes

Am I missing something in the build steps or there's a problem with the
Oreo branch?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Harkaman
2018-08-10 18:40:09 UTC
Permalink
Did you add this gapps?

https://github.com/opengapps/aosp_build
Post by BrokenE39
I gave up on just copying the kernel and drivers over to a generic install
since I couldn't get "module_install" to run without errors. I manage to
build an ISO image based on custom configuration file but I notice the
1. On first start up, I don't see the typical setup wizard
2. Notice Google Play is missing which isn't missing if I use the generic
ISO
3. Setup crashes
Am I missing something in the build steps or there's a problem with the
Oreo branch?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Daniel Cheung
2018-08-10 18:46:48 UTC
Permalink
I was thinking about using OpenGapps but I can't get my Wifi to connect
since Setup won't run so I can't select my access point to connect out to
the Internet.
Post by Harkaman
Did you add this gapps?
https://github.com/opengapps/aosp_build
Post by BrokenE39
I gave up on just copying the kernel and drivers over to a generic
install since I couldn't get "module_install" to run without errors. I
manage to build an ISO image based on custom configuration file but I
1. On first start up, I don't see the typical setup wizard
2. Notice Google Play is missing which isn't missing if I use the generic
ISO
3. Setup crashes
Am I missing something in the build steps or there's a problem with the
Oreo branch?
--
You received this message because you are subscribed to the Google Groups
"Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Daniel Cheung
2018-08-10 18:49:28 UTC
Permalink
Sorry I think I misunderstood your original comment. No, I didn't include
OpenGapps in the build process. My last comment was made because I was
thinking of it as a Zip file that I just load from TWRP, which doesn't
apply for Android-X86.
Post by Daniel Cheung
I was thinking about using OpenGapps but I can't get my Wifi to connect
since Setup won't run so I can't select my access point to connect out to
the Internet.
Post by Harkaman
Did you add this gapps?
https://github.com/opengapps/aosp_build
Post by BrokenE39
I gave up on just copying the kernel and drivers over to a generic
install since I couldn't get "module_install" to run without errors. I
manage to build an ISO image based on custom configuration file but I
1. On first start up, I don't see the typical setup wizard
2. Notice Google Play is missing which isn't missing if I use the
generic ISO
3. Setup crashes
Am I missing something in the build steps or there's a problem with the
Oreo branch?
--
You received this message because you are subscribed to the Google Groups
"Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Daniel Cheung
2018-08-11 23:22:06 UTC
Permalink
Following the OpenGapps integration script, I managed to get Google Play
store and the setup wizard working. However, Settings still crashes when I
open it up. Is there a way to retrieve the logs without using log cat?
Post by Daniel Cheung
Sorry I think I misunderstood your original comment. No, I didn't include
OpenGapps in the build process. My last comment was made because I was
thinking of it as a Zip file that I just load from TWRP, which doesn't
apply for Android-X86.
Post by Daniel Cheung
I was thinking about using OpenGapps but I can't get my Wifi to connect
since Setup won't run so I can't select my access point to connect out to
the Internet.
Post by Harkaman
Did you add this gapps?
https://github.com/opengapps/aosp_build
Post by BrokenE39
I gave up on just copying the kernel and drivers over to a generic
install since I couldn't get "module_install" to run without errors. I
manage to build an ISO image based on custom configuration file but I
1. On first start up, I don't see the typical setup wizard
2. Notice Google Play is missing which isn't missing if I use the
generic ISO
3. Setup crashes
Am I missing something in the build steps or there's a problem with the
Oreo branch?
--
You received this message because you are subscribed to the Google
Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
BrokenE39
2018-08-12 08:10:39 UTC
Permalink
Well since Settings keep crashing, I tried the 7.1 source instead and build
a new image withotu GAPPS for testing. Without GAPPS, it worked great, wifi
works, touch works, rotation is stuck but I haven't got around to fix it
yet. However, when I use the OpenGAPPS integration script method of
including Open Gapps, the initial setup wizard ends up in a crash loop.
Looking at the Github project page for OpenGapps for ASOP, I'm unsure of
the instruction since the folder structure for Android X86 is a bit
different.

* Which device.mk should I edit? The one in /device/generic/common/?

* Where do I put the opengapps-packages.mk file? Just make a folder
structure similar to the instruction?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Harkaman
2018-08-12 12:13:58 UTC
Permalink
in .repo/manifests/default.xml add this:

<!-- BEGIN OPENGAPPS-X86 -->

<remote name="opengapps" fetch="https://github.com/opengapps/" />

<project path="vendor/opengapps/build" name="aosp_build" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/all" name="all" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86" name="x86" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86_64" name="x86_64" clone-depth="1" revision="master" remote="opengapps" />

<!-- END OPENGAPPS-X86 -->

device/device/generic/common/device.mk add this:

#OpenGAPPS

GAPPS_VARIANT := pico


GAPPS_FORCE_BROWSER_OVERRIDES := true

GAPPS_EXCLUDED_PACKAGES := FaceLock \
AndroidPlatformServices \
PrebuiltGmsCoreInstantApps \

#OpenGAPPS
$(call inherit-product, vendor/opengapps/build/opengapps-packages.mk) (add this line at the end)


[image: 123.jpg] <about:invalid#zClosurez>

[image: 456.jpg] <about:invalid#zClosurez>
Post by BrokenE39
Well since Settings keep crashing, I tried the 7.1 source instead and
build a new image withotu GAPPS for testing. Without GAPPS, it worked
great, wifi works, touch works, rotation is stuck but I haven't got around
to fix it yet. However, when I use the OpenGAPPS integration script method
of including Open Gapps, the initial setup wizard ends up in a crash loop.
Looking at the Github project page for OpenGapps for ASOP, I'm unsure of
the instruction since the folder structure for Android X86 is a bit
different.
* Which device.mk should I edit? The one in /device/generic/common/?
* Where do I put the opengapps-packages.mk file? Just make a folder
structure similar to the instruction?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Harkaman
2018-08-12 12:17:36 UTC
Permalink
For Nougat x86

in .repo/manifests/default.xml add this:

<!-- BEGIN OPENGAPPS-X86 -->

<remote name="opengapps" fetch="https://github.com/opengapps/" />

<project path="vendor/opengapps/build" name="aosp_build" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/all" name="all" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86" name="x86" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86_64" name="x86_64" clone-depth="1" revision="master" remote="opengapps" />

<!-- END OPENGAPPS-X86 -->

[image: 123.jpg] <about:invalid#zClosurez>

[image: 456.jpg] <about:invalid#zClosurez>

In device/device/generic/common/device.mk add this:

#OpenGAPPS

GAPPS_VARIANT := pico


GAPPS_FORCE_BROWSER_OVERRIDES := true

GAPPS_EXCLUDED_PACKAGES := FaceLock \
AndroidPlatformServices \
PrebuiltGmsCoreInstantApps \

#OpenGAPPS
$(call inherit-product, vendor/opengapps/build/opengapps-packages.mk) (add this line at the end)

[image: 456.jpg] <about:invalid#zClosurez>

[image: 123.jpg] <about:invalid#zClosurez>
It works for me.
Post by BrokenE39
Well since Settings keep crashing, I tried the 7.1 source instead and
build a new image withotu GAPPS for testing. Without GAPPS, it worked
great, wifi works, touch works, rotation is stuck but I haven't got around
to fix it yet. However, when I use the OpenGAPPS integration script method
of including Open Gapps, the initial setup wizard ends up in a crash loop.
Looking at the Github project page for OpenGapps for ASOP, I'm unsure of
the instruction since the folder structure for Android X86 is a bit
different.
* Which device.mk should I edit? The one in /device/generic/common/?
* Where do I put the opengapps-packages.mk file? Just make a folder
structure similar to the instruction?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Daniel Cheung
2018-08-12 22:03:52 UTC
Permalink
Thank you for confirming the instructions. I notice you are using pico
instead of full, is that for personal reason (less junk) or a compatibility
issue? I read the note on OpenGapps that anything above stock may not work
with Android X86.
Post by Harkaman
For Nougat x86
<!-- BEGIN OPENGAPPS-X86 -->
<remote name="opengapps" fetch="https://github.com/opengapps/" />
<project path="vendor/opengapps/build" name="aosp_build" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/all" name="all" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86" name="x86" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86_64" name="x86_64" clone-depth="1" revision="master" remote="opengapps" />
<!-- END OPENGAPPS-X86 -->
[image: 123.jpg]
[image: 456.jpg]
#OpenGAPPS
GAPPS_VARIANT := pico
GAPPS_FORCE_BROWSER_OVERRIDES := true
GAPPS_EXCLUDED_PACKAGES := FaceLock \
AndroidPlatformServices \
PrebuiltGmsCoreInstantApps \
#OpenGAPPS
$(call inherit-product, vendor/opengapps/build/opengapps-packages.mk) (add this line at the end)
[image: 456.jpg]
[image: 123.jpg]
It works for me.
Post by BrokenE39
Well since Settings keep crashing, I tried the 7.1 source instead and
build a new image withotu GAPPS for testing. Without GAPPS, it worked
great, wifi works, touch works, rotation is stuck but I haven't got around
to fix it yet. However, when I use the OpenGAPPS integration script method
of including Open Gapps, the initial setup wizard ends up in a crash loop.
Looking at the Github project page for OpenGapps for ASOP, I'm unsure of
the instruction since the folder structure for Android X86 is a bit
different.
* Which device.mk should I edit? The one in /device/generic/common/?
* Where do I put the opengapps-packages.mk file? Just make a folder
structure similar to the instruction?
--
You received this message because you are subscribed to the Google Groups
"Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Daniel Cheung
2018-08-12 23:25:41 UTC
Permalink
Hmm, I'm getting folder not found error for /vendor/opengapps/build/
opengapps-package.mk. If I manually create the folder structure, I'm
getting folder not found for /vendor/opengapps/build/source. It seems that
it's not grabbing the source during build.
Post by Daniel Cheung
Thank you for confirming the instructions. I notice you are using pico
instead of full, is that for personal reason (less junk) or a compatibility
issue? I read the note on OpenGapps that anything above stock may not work
with Android X86.
Post by Harkaman
For Nougat x86
<!-- BEGIN OPENGAPPS-X86 -->
<remote name="opengapps" fetch="https://github.com/opengapps/" />
<project path="vendor/opengapps/build" name="aosp_build" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/all" name="all" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86" name="x86" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86_64" name="x86_64" clone-depth="1" revision="master" remote="opengapps" />
<!-- END OPENGAPPS-X86 -->
[image: 123.jpg]
[image: 456.jpg]
#OpenGAPPS
GAPPS_VARIANT := pico
GAPPS_FORCE_BROWSER_OVERRIDES := true
GAPPS_EXCLUDED_PACKAGES := FaceLock \
AndroidPlatformServices \
PrebuiltGmsCoreInstantApps \
#OpenGAPPS
$(call inherit-product, vendor/opengapps/build/opengapps-packages.mk) (add this line at the end)
[image: 456.jpg]
[image: 123.jpg]
It works for me.
Post by BrokenE39
Well since Settings keep crashing, I tried the 7.1 source instead and
build a new image withotu GAPPS for testing. Without GAPPS, it worked
great, wifi works, touch works, rotation is stuck but I haven't got around
to fix it yet. However, when I use the OpenGAPPS integration script method
of including Open Gapps, the initial setup wizard ends up in a crash loop.
Looking at the Github project page for OpenGapps for ASOP, I'm unsure of
the instruction since the folder structure for Android X86 is a bit
different.
* Which device.mk should I edit? The one in /device/generic/common/?
* Where do I put the opengapps-packages.mk file? Just make a folder
structure similar to the instruction?
--
You received this message because you are subscribed to the Google Groups
"Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Daniel Cheung
2018-08-13 05:43:11 UTC
Permalink
After syncing the repo, I manage to get the build to include opengapps.
However, the setup wizard keep crashing so that's something I have to look
into.
Hmm, I'm getting folder not found error for /vendor/opengapps/build/openga
pps-package.mk. If I manually create the folder structure, I'm getting
folder not found for /vendor/opengapps/build/source. It seems that it's
not grabbing the source during build.
Post by Daniel Cheung
Thank you for confirming the instructions. I notice you are using pico
instead of full, is that for personal reason (less junk) or a compatibility
issue? I read the note on OpenGapps that anything above stock may not work
with Android X86.
Post by Harkaman
For Nougat x86
<!-- BEGIN OPENGAPPS-X86 -->
<remote name="opengapps" fetch="https://github.com/opengapps/" />
<project path="vendor/opengapps/build" name="aosp_build" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/all" name="all" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86" name="x86" clone-depth="1" revision="master" remote="opengapps" />
<project path="vendor/opengapps/sources/x86_64" name="x86_64" clone-depth="1" revision="master" remote="opengapps" />
<!-- END OPENGAPPS-X86 -->
[image: 123.jpg]
[image: 456.jpg]
#OpenGAPPS
GAPPS_VARIANT := pico
GAPPS_FORCE_BROWSER_OVERRIDES := true
GAPPS_EXCLUDED_PACKAGES := FaceLock \
AndroidPlatformServices \
PrebuiltGmsCoreInstantApps \
#OpenGAPPS
$(call inherit-product, vendor/opengapps/build/opengapps-packages.mk) (add this line at the end)
[image: 456.jpg]
[image: 123.jpg]
It works for me.
Post by BrokenE39
Well since Settings keep crashing, I tried the 7.1 source instead and
build a new image withotu GAPPS for testing. Without GAPPS, it worked
great, wifi works, touch works, rotation is stuck but I haven't got around
to fix it yet. However, when I use the OpenGAPPS integration script method
of including Open Gapps, the initial setup wizard ends up in a crash loop.
Looking at the Github project page for OpenGapps for ASOP, I'm unsure of
the instruction since the folder structure for Android X86 is a bit
different.
* Which device.mk should I edit? The one in /device/generic/common/?
* Where do I put the opengapps-packages.mk file? Just make a folder
structure similar to the instruction?
--
You received this message because you are subscribed to the Google
Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Loading...