Discussion:
Failure in android x86 CTSLibCoreTestCases
(too old to reply)
Harinath Maddela
2018-11-16 02:42:46 UTC
Permalink
Hi,

I'm trying to run CTS on android x86 AMD Ryzen 5 2400G Processor with
Radeon RX Vega 11 Graphics, with GIGABYTE -GA-AB350N-Gaming motherboard,
Android Version is 7.1.2(r36) with user debug build.

While trying to run CTSLibCoreTestCases, it gives failures in
libcore.java.net.ConcurrentCloseTest#test_connect,
libcore.java.net.ConcurrentCloseTest#test_connect_nonBlocking,
libcore.java.net.ConcurrentCloseTest#test_connect_timeout. All these are
concurrent close test cases while connecting. The test case expects Socket
closed exception while trying to connect socket. However in my case the
socket connection happens properly and that results in failure of test case.

I tried to analyze the code and found out that the test case has main
thread where socket connect is attempted and there is a thread that has
been created prior to connect call, which does close socket. So as socket
connect is attempted socket closed is called from the other thread and will
result in socket closed exception for call to socket connect. There is a
delay in close thread with call Thread.sleep of 2 sec. However it does not
seem to return from this call. Not sure this if thats an issue with
thread.sleep or the main thread got returned before this execution of close
is done. This looks like some kind of synchronization issue. I tried to
remove the sleep in close thread and the test case succeeds sometimes.

Any suggestions could help in debugging this issue further.

Thanks,
Harinath
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Continue reading on narkive:
Loading...