Discussion:
BatteryManager Service
(too old to reply)
Jose Luis s
2018-11-08 10:00:41 UTC
Permalink
Hi all.

I need for one of my projects with android-x86 that my tablet works with a
lot of usb devices connected and connected to power, but as most intel
tablets there is only an OTG microusb connector. I've tried most of the
proposed solutions from inet, even bought 4-5 otg hubs that claimed to work
in a otg mode and charging simultaneously, but only get them working in
Windows not in android-x86 (same EFI configuration)
Some DIY seems to point in the good direction but I didn't found the right
resistor value to activate charging and otg at the same time, also in some
designs a switch is needed and this is not an option for my project.

So I search for some different aproaches, from trying to use usbip from my
router, no way because I don't find any alternative to usbip userland tools
in android, and some similar.

The last I tried is to use some external Battery charger controller to my
battery and use the otg as otg usb host. I seems to work fine but I've
found that the battery gauge service reports the Battery charge status from
some register not related to Battery voltage, so Android thinks that the
battery is empty after some hours despite the battery is fully charge.
So I need to disconnect the external charger controller and charge again
using the internal charger circuit in my tablet.

Batterystats.bin file reset (root erase) does not help at all, the tablet
think that the battery is empty and even does not boot at all when
android-x86 try to boot, probably due to Batterymanager service.

Of course I cannot edit or modify /sys/class/ filesystem even root to
modify the uevent or other battery info file.

Also try to use dumpsys battery set to modify the values, this works in one
session but the values are lost after the tablet reboot.


Can anybody help with an alternative?

A specific Android-x86 compilation without battery maybe? I've found a
patch to change the sources, but I never was able to compile the whole
source (don't know why) only kernel.....

I've tried to blacklist the kernel module at boot but then my tablet does
not boot.

Please help
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Continue reading on narkive:
Loading...