Discussion:
Some problem on ezpad6pro (and fix)
(too old to reply)
chalesyu
2018-12-01 12:06:53 UTC
Permalink
Hi
I'm installed 8.1-rc2 on this tablet, but I found some problem when I'm using.

SD card reader is not work ,id is 0bda:0129, it's a RTS5129, need CONFIG_MISC_RTSX_USB (and some depend).

about wifi , I'm using rtl8821au (0bda:0823) ,It can work by using rtl8812au driver , but the driver in kernel source is too old , doesn't include my device id . Although I tried to add my device id into os_dep/usb_intf.c ,it can only scan AP but can't connect. luckily ,I can found useable driver on Internet . Chih-Wei , if you need, I can provide a newer driver resource for you.

about iio driver (bosc0200 g-sensor), I decided to use iio-old HAL . Because I can confirm the iio HAL is not work for me, but iio-old HAL can work and stable enough.
by the way, i think this patch is useless
http://git.osdn.net/view?p=android-x86/device-generic-common.git;a=commit;h=495685b9d093bb0c99e1c88a54cab5bdb01188f3
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Jon West
2018-12-01 17:48:50 UTC
Permalink
I actually found these and am considering making them modules in
device/generic/common, https://github.com/arnoldthebat/rtlwifi_new
, https://github.com/arnoldthebat/rtl8723au
, https://github.com/arnoldthebat/rtl8188eu
& https://github.com/arnoldthebat/rtl8723bu . If you can also find one for
the rtl8821au, you can test adding it there by using this as an
example: https://github.com/BlissRoms-x86/device_generic_common/commit/c792f4649998154ed5762d252db944c18b8c6a27
Post by chalesyu
Hi
I'm installed 8.1-rc2 on this tablet, but I found some problem when I'm using.
SD card reader is not work ,id is 0bda:0129, it's a RTS5129, need
CONFIG_MISC_RTSX_USB (and some depend).
about wifi , I'm using rtl8821au (0bda:0823) ,It can work by using
rtl8812au driver , but the driver in kernel source is too old , doesn't
include my device id . Although I tried to add my device id into
os_dep/usb_intf.c ,it can only scan AP but can't connect. luckily ,I can
found useable driver on Internet . Chih-Wei , if you need, I can provide a
newer driver resource for you.
about iio driver (bosc0200 g-sensor), I decided to use iio-old HAL .
Because I can confirm the iio HAL is not work for me, but iio-old HAL can
work and stable enough.
by the way, i think this patch is useless
http://git.osdn.net/view?p=android-x86/device-generic-common.git;a=commit;h=495685b9d093bb0c99e1c88a54cab5bdb01188f3
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Yu Zhao
2018-12-02 02:14:02 UTC
Permalink
I'm using this source without problem
https://github.com/kimocoder/rtl8812au/tree/v5.1.5
unfortunately, this driver is not in mainline kernel

but for wifi driver ,why not replace drivers/staging/rtl8812au folder in
kernel source?
Post by Jon West
I actually found these and am considering making them modules in
device/generic/common, https://github.com/arnoldthebat/rtlwifi_new ,
https://github.com/arnoldthebat/rtl8723au , https://github.com/
arnoldthebat/rtl8188eu & https://github.com/arnoldthebat/rtl8723bu . If
you can also find one for the rtl8821au, you can test adding it there by
using this as an example: https://github.com/BlissRoms-x86/device_generic_
common/commit/c792f4649998154ed5762d252db944c18b8c6a27
Post by chalesyu
Hi
I'm installed 8.1-rc2 on this tablet, but I found some problem when I'm using.
SD card reader is not work ,id is 0bda:0129, it's a RTS5129, need
CONFIG_MISC_RTSX_USB (and some depend).
about wifi , I'm using rtl8821au (0bda:0823) ,It can work by using
rtl8812au driver , but the driver in kernel source is too old , doesn't
include my device id . Although I tried to add my device id into
os_dep/usb_intf.c ,it can only scan AP but can't connect. luckily ,I can
found useable driver on Internet . Chih-Wei , if you need, I can provide a
newer driver resource for you.
about iio driver (bosc0200 g-sensor), I decided to use iio-old HAL .
Because I can confirm the iio HAL is not work for me, but iio-old HAL can
work and stable enough.
by the way, i think this patch is useless
http://git.osdn.net/view?p=android-x86/device-generic-common
.git;a=commit;h=495685b9d093bb0c99e1c88a54cab5bdb01188f3
--
You received this message because you are subscribed to the Google Groups
"Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
chalesyu
2018-12-02 13:18:45 UTC
Permalink
Just want to explain how i can make rtl8821au worked .
driver is download from
https://www.edimax.com/edimax/download/download/data/edimax/global/download/for_home/wireless_adapters/wireless_adapters_ac600_dual-band/ew-7811uac

I select linux driver to downloadfile name is EW-7811UTC_UAC_DAC_USC_Linux_Driver_1.0.2.4.zip
then unzip and compile it. It works without problem. but this driver looks only support rtl8821au , not support 8812au/8814au i think.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+***@googlegroups.com.
To post to this group, send email to android-***@googlegroups.com.
Visit this group at https://groups.google.com/group/android-x86.
For more options, visit https://groups.google.com/d/optout.
Continue reading on narkive:
Loading...