Discussion:
HELP!! Android-x86 4.2 can't boot into gui,just command line
(too old to reply)
Teten Kurniawan
2013-01-08 06:04:05 UTC
Permalink
i just install Android-x86 4.2 successfull but when its boot,just go into
Akram Berkawy
2013-01-08 10:26:00 UTC
Permalink
same issue here on vmware
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/TifbnZc3b4wJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Maksim Lin
2013-01-14 03:35:33 UTC
Permalink
Hi, I'm also seeing this with qemu-kvm.

I've attached a screenshot with the error messages.
Surfaceflinger is segfaulting - perhaps due to the error about missing .rc
file that happens just before that?
Post by Akram Berkawy
same issue here on vmware
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/Tj6kFNU_FbkJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Lowell Kim
2013-01-15 17:34:56 UTC
Permalink
Are you booting from kvm command line? Try adding "-vga std" to it.
Post by Maksim Lin
Hi, I'm also seeing this with qemu-kvm.
I've attached a screenshot with the error messages.
Surfaceflinger is segfaulting - perhaps due to the error about missing .rc
file that happens just before that?
Post by Akram Berkawy
same issue here on vmware
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go
into command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/68LTYTs42zgJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Maksim Lin
2013-01-16 01:41:54 UTC
Permalink
Hi,
yes, i'm running kvm with a cmdlien like this:

kvm -soundhw es1370 -net nic -net user -cdrom
~/Downloads/android-x86-4.2-20121225.iso

but I'm afraid adding -vga std did not help.
Are you able to boot that 4.2 ISO all the way into the full andoird GUI
using kvm?

As I said in my previous email, the problem is that surfaceflinger is
segfaulting, but this is after the FB driver switches the display to a
higher res, so I'm not sure its to do with the gfx driver itself.

Maks.
Post by Lowell Kim
Are you booting from kvm command line? Try adding "-vga std" to it.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/5Uvjom4n48UJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Lowell Kim
2013-01-16 07:17:42 UTC
Permalink
Hi Maks,

I just tried that ISO, and I get the same error. I AM able to boot other
ISOs though. I'm currently using a 4.0.4rc2 I built myself.

Lowell
Post by Maksim Lin
Hi,
kvm -soundhw es1370 -net nic -net user -cdrom
~/Downloads/android-x86-4.2-20121225.iso
but I'm afraid adding -vga std did not help.
Are you able to boot that 4.2 ISO all the way into the full andoird GUI
using kvm?
As I said in my previous email, the problem is that surfaceflinger is
segfaulting, but this is after the FB driver switches the display to a
higher res, so I'm not sure its to do with the gfx driver itself.
Maks.
Post by Lowell Kim
Are you booting from kvm command line? Try adding "-vga std" to it.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/tlZmXseqlHMJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Shuai Lin
2013-01-14 07:57:33 UTC
Permalink
I also have the same problem.

Details:

HOST: Ubuntu Linux 12.04 64-bit
Virtual Box 4.2
Vmware Workstation 8.2

圚 2013幎1月8日星期二UTC+8䞋午2时04分05秒Teten Kurniawan写道
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/vCLeTnqwBcIJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+***@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Yahya Makhrsh
2013-01-16 11:33:44 UTC
Permalink
<Loading Image...>
me to i cannot running it
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/Q8DLJFJIVi4J.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Dimitrios Misdanitis
2013-01-16 22:28:51 UTC
Permalink
Confirmed on Sony Vaio E Series netbook with AMD E2-1800 APU and AMD Radeon
HD 7340. Boots up very fast, but drops me into root shell. If I use the
kernel boot option "xforcevesa" gui is displayed for a split second and
then i'm dropped back to the shell. Is there a command to manually start
the X server, like "startx" is on linux.
Post by Yahya Makhrsh
<https://lh5.googleusercontent.com/-9GWpBX7Hhog/UPaQCoDMakI/AAAAAAAAAaw/TBlYDTlxic8/s1600/saUH.jpg>
me to i cannot running it
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/XWmS0L4NFD0J.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
王波涛
2013-01-17 01:38:38 UTC
Permalink
N.H.G
2013-01-20 06:03:00 UTC
Permalink
same issue on my device.
Uoc Nguyen
2013-01-22 08:12:53 UTC
Permalink
Same here with Virtual box, I ran into debug mode and see some error
related to tty, look like init process can not create tty device.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/_mzXJsVMtn4J.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Uoc Nguyen
2013-01-22 09:22:59 UTC
Permalink
Forgot to tell you that console show some error about some system process
got segfault and died already, the message re-appear each 10 seconds. IMO,
it is caused by some process cannot start and boot process gets looped
infinitively.
Post by Uoc Nguyen
Same here with Virtual box, I ran into debug mode and see some error
related to tty, look like init process can not create tty device.
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/4j3PVzUkZlcJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
Pablo Beltran Alvarez Sierra
2013-01-22 22:56:46 UTC
Permalink
init: could not import file '/init.android_x86.rc' from '/init.rc'
In fact that file doesn't exist, instead there is an 'init.x86.rc' one.
Could this be the cause of the problems?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/K1ijUtBb40YJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
eugene pofig
2013-01-23 09:50:33 UTC
Permalink
I had something like that. I didn't install android to my HDD. I've been
trying to run it in Live mode and couldn't get GUI work. Finally I've
changed GRUB boot parameters like this:

........... initrd=/initrd.img root=/dev/ram0
androidboot.hardware=android_x86 video=-16* nomodeset vga=(any unreal mode
such as 987877 or 5785 etc)* ..........

GRUB offered me to change the vga mode - to choose one from table. I've
selected 1024x768 16bit mode (32 bit gave me something unusable). It works
for me. My GUI started. But where is Google Play & how to manage my Google
accounts ?? Without these features android is useless....(sorry for my
english)
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To view this discussion on the web visit https://groups.google.com/d/msg/android-x86/-/kzUfgh6kFdwJ.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
For more options, visit this group at http://groups.google.com/group/android-x86?hl=en.
eugene pofig
2013-01-25 09:57:21 UTC
Permalink
Post by eugene pofig
I had something like that. I didn't install android to my HDD. I've been
trying to run it in Live mode and couldn't get GUI work. Finally I've
........... initrd=/initrd.img root=/dev/ram0
androidboot.hardware=android_x86 video=-16* nomodeset vga=(any unreal
mode such as 987877 or 5785 etc)* ..........
GRUB offered me to change the vga mode - to choose one from table. I've
selected 1024x768 16bit mode (32 bit gave me something unusable). It works
for me. My GUI started. But where is Google Play & how to manage my Google
accounts ?? Without these features android is useless....(sorry for my
english)
Sorry, I forgot to note - I'm using build from tabletsx86.org . My
hardware config: core i5 750, 4Gb RAM, Radeon HD 7870....It's seems to me
that Android lack to recognize my PATA DVD-Rom connected to JMicron
controller...
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+***@googlegroups.com.
Visit this group at http://groups.google.com/group/android-x86?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
a***@public.gmane.org
2013-01-26 00:30:58 UTC
Permalink
Got it working in VirtualBox after selecting the VESA mode from the menu,
then change the parameter "androidboot.hardware=x86".
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To unsubscribe from this group, send email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
Visit this group at http://groups.google.com/group/android-x86?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
Fei Sun
2013-02-02 18:51:35 UTC
Permalink
Thank you,this works for me.
Post by a***@public.gmane.org
Got it working in VirtualBox after selecting the VESA mode from the menu,
then change the parameter "androidboot.hardware=x86".
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
Visit this group at http://groups.google.com/group/android-x86?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
ix
2013-03-15 19:52:25 UTC
Permalink
J da Costa
2013-03-18 02:02:02 UTC
Permalink
Hi guys,

Tried every tip in here none worked :( ... any ideas? Running on VMware
Workstation 9.0.2 64 bit.

thks
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
Visit this group at http://groups.google.com/group/android-x86?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
Baloo Bear
2013-03-21 09:36:03 UTC
Permalink
I've installed android-x86-4.2-20121225.iso on Virtual Box
(VirtualBox-4.2.10-84105-Win) and failed to run ((
Attempting to run it I have (attached png-file)
((
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
Visit this group at http://groups.google.com/group/android-x86?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
Blake W. Ford
2013-03-23 01:58:57 UTC
Permalink
Is there a solution to this problem for the eeepc 701?
Post by Teten Kurniawan
i just install Android-x86 4.2 successfull but when its boot,just go into
command line..what can i do to get into gui interface?
--
You received this message because you are subscribed to the Google Groups "Android-x86" group.
To unsubscribe from this group and stop receiving emails from it, send an email to android-x86+unsubscribe-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
To post to this group, send email to android-x86-/JYPxA39Uh5TLH3MbocFF+G/***@public.gmane.org
Visit this group at http://groups.google.com/group/android-x86?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.
Continue reading on narkive:
Loading...